Skip to main content

DJ-Catalog2 and the Integrator Plugin with the full Joomla 5 compatibility

DJ-Catalog2 and the Integrator Plugin for Joomla 5

The wait is finally over! DJ-Catalog2 and the DJ-Catalog2 Integrator Plugin are now fully compatible with Joomla 5!

Enjoy upgraded features and seamless integration with the latest stable versions.

Huge thanks to our amazing users for your invaluable feedback during our beta releases. You've helped us squash bugs and make this launch a success!
 
Update now and experience the difference! 

Get DJ-Catalog2, Joomla 5 eCommerce extension.

Get DJ-Catalog2 Integrator plugin for Joomla 5, integrating YOOtheme Pro with DJ-Catalog2.